UMLe Data Structure Server

Object Model


References

FileName | Version | Size | Description
STDOLE2.TLB | 2.40.4275.1 | 17920 | OLE Automation


Cell object

This is the Cell oject. It implements the main caracteristics for the basic layout cell.


CellInstance object

A cell's instance within other cell.


Global object

This class implements the enumerations.


Label object

The Label object.


Layer object

UMLe - Universidade do Minho - Departamento de Informática 1998

Tipo - Classe
Descrição - Classe que representa uma camada associada a um dado material
material.

Autor - Jorge Duarte Sottomaior Braga Baptista


LayoutProject object

The main root object.


Point object

UMLe - Universidade do Minho - Departamento de Informática 1998

Tipo - Classe
Descrição - Classe que representa um Point com coordenadas X e Y
Autor - Jorge Duarte Sottomaior Braga Baptista
This is the point object.


Rectangle object

This is the rectangle object.


Rule object

Implements a DRC design rule .


CellInstances collection

Returns the collection of the instanciated cells.

Collection type

A CellInstances collection.

Syntax

[Set] object.CellInstances [= CellInstances]

The CellInstances property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
CellInstances | A CellInstances collection.


CellInstances collection

This property is still under development.

Collection type

A CellInstances collection.

Syntax

object.CellInstances

The CellInstances property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.


CellInstances collection

The CellInstances collection within a cell.


Cells collection

Collection type

A Cells collection.

Syntax

[Set] object.Cells [= Cells]

The Cells property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
Cells | A Cells collection.


Cells collection

The Cells collection within a LayoutProject. This collection is also a tree since it's objects are connected as so.


Envelope collection

Returns the cell's Envelope. The Cell's envelope defines the boundary of the Cell.

Collection type

An Envelope collection.

Syntax

[Set] object.Envelope [= Envelope]

The Envelope property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
Envelope | An Envelope collection.


Envelope collection

The Cell's envelope.


Labels collection

Returns a Labels collection containing all the labels present in the refered Cell object.

Collection type

A Labels collection.

Syntax

[Set] object.Labels [= Labels]

The Labels property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
Labels | A Labels collection.


Labels collection

This property is still under development.

Collection type

A Labels collection.

Syntax

object.Labels

The Labels property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.


Labels collection

The Labels collection.


Layers collection

Collection type

A Layers collection.

Syntax

[Set] object.Layers [= Layers]

The Layers property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
Layers | A Layers collection.


Layers collection

UMLe - Universidade do Minho - Departamento de Informática 1998

Tipo - Classe/Colecção
Descrição - Classe que representa uma colecção de objectos do tipo Camada

Autor - Jorge Duarte Sottomaior Braga Baptista
The Layers collection


Rectangles collection

Returns the collection of the rectangles within the Cell's boundary.

Collection type

A Rectangles collection.

Syntax

[Set] object.Rectangles [= Rectangles]

The Rectangles property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
Rectangles | A Rectangles collection.


Rectangles collection

This property is still under development.

Collection type

A Rectangles collection.

Syntax

object.Rectangles

The Rectangles property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.


Rectangles collection

The Rectangles collection


Rules collection

Collection type

A Rules collection.

Syntax

[Set] object.Rules [= Rules]

The Rules property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
Rules | A Rules collection.


Rules collection

The Rules collection


Add method

Adds a new CellInstance to the collection.

Return Type

A CellInstance object.

Syntax

object.Add (X, Y, IsMaster, PointedCell[, ID])

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstances.
X | Required. A Long value. X coordenate of placement.
Y | Required. A Long value. Y coordenate of placement.
IsMaster | Required. A Boolean value.
PointedCell | Required. A Cell object. The cell being instanciated.
ID | Optional. A String value. the new internal ID for the new instance.


Add method

Adds a new Cell to the collection. This method simply creates the new Cell in the collection. All other propertys must be set later.

Return Type

A Cell object.

Syntax

object.Add ([ID])

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cells.
ID | Optional. A String value. The internal ID for the new Cell. If this parameter is not assigned, it will be created automatically.


Add method

Adds a new point to the envelope.

Return Type

A Point object.

Syntax

object.Add (X, Y)

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Envelope.
X | Required. A Long value. X coordenate.
Y | Required. A Long value. Y coordenate.


Add method

Adds a new Label.

Return Type

A Label object.

Syntax

object.Add (Caption, X, Y, Font, Size[, ID])

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Labels.
Caption | Required. A String value.
X | Required. A Long value.
Y | Required. A Long value.
Font | Required. A String value.
Size | Required. A Byte value.
ID | Optional. A String value.


Add method

Adds a new Layer.

Return Type

A Layer object.

Syntax

object.Add (Color, Pattern, Name, Token, ZOrder[, ID])

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.
Color | Required. An OLE_COLOR object.
Pattern | Required. A FillStyleConstants object.
Name | Required. A String value.
Token | Required. A String value.
ZOrder | Required. A Byte value.
ID | Optional. A String value.


Add method

Adds a new Rectangle.

Return Type

A Rectangle object.

Syntax

object.Add (X1, Y1, X2, Y2, Name, Layer[, ID])

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangles.
X1 | Required. A Long value.
Y1 | Required. A Long value.
X2 | Required. A Long value.
Y2 | Required. A Long value.
Name | Required. A String value.
Layer | Required. A Layer object.
ID | Optional. A String value.


Add method

Adds a new rule.

Return Type

A Rule object.

Syntax

object.Add (Name, Active, RuleType, IgnoreCoincidences, IgnoreIntersections, IgnoreIfL1OutsideL2, Ignore45, Distance, DistanceType, Layer1, Layer2[, ID])

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.
Name | Required. A String value. The name of the new Rule
Active | Required. A Boolean value.
RuleType | Required. A drcRuleTypeConstants value, as described in settings.
IgnoreCoincidences | Required. A Boolean value.
IgnoreIntersections | Required. A Boolean value.
IgnoreIfL1OutsideL2 | Required. A Boolean value.
Ignore45 | Required. A Boolean value.
Distance | Required. A Long value.
DistanceType | Required. A drcDistanceTypeConstants value, as described in settings.
Layer1 | Required. A Layer object.
Layer2 | Required. A Layer object.
ID | Optional. A String value.

Settings

The settings for RuleType are:

Constant | Description
drcRuleTypeMinWidth | Minimum width
drcRuleTypeExactWidth | Exact width
drcRuleTypeNotExist | Not exist
drcRuleTypeOverlap | Overlap
drcRuleTypeSpacing | Spacing
drcRuleTypeSurround | Surround
drcRuleTypeExtension | Extension

The settings for DistanceType are:

Constant | Description
drcDistanceTypeAbsoluteValue | Absolute Value based measurements.
drcDistanceTypeLambda | Lambda based measurements.


Clear method

Clears the collection contents

Syntax

object.Clear

The Clear method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangles.


Clear method

Clears the collection

Syntax

object.Clear

The Clear method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.


Count method

Returns a long containing the number of elements in the collection.

Return Type

A Long value.

Syntax

object.Count

The Count method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangles.


Intersects method

Returns a boolean value indicating if the poin X,Y is inside the envelope.

Return Type

A Boolean value.

Syntax

object.Intersects (X, Y)

The Intersects method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Envelope.
X | Required. A Long value. X coordenate.
Y | Required. A Long value. Y coordenate.


Load method

Loads a Cell from disk given a filename. It doesn't alter the Cell's FileName property. Filename must be a complete file name ( path included ) e.g. "C:\UMLE\PROJECT1.UML"

Syntax

object.Load [FileName]

The Load method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
FileName | Optional. A String value. - a complete path to a UML file.


Load method

Syntax

object.Load

The Load method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.


Load method

Load's all the project's files.

Syntax

object.Load

The Load method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.


Load method

Syntax

object.Load

The Load method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.


LoadStructure method

Loads project's structure.

Syntax

object.LoadStructure

The LoadStructure method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.


Refresh method

Refreshs the Cells contents and validates aditional information namely LUC, RLC and collection indexes.

Syntax

object.Refresh

The Refresh method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.


Remove method

Removes a member from the collection given an internal ID

Syntax

object.Remove vntIndexKey

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstances.
vntIndexKey | Required. A Variant value.


Remove method

Removes a member from the collection given an internal ID

Syntax

object.Remove vntIndexKey

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cells.
vntIndexKey | Required. A Variant value.


Remove method

Syntax

object.Remove vntIndexKey

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Envelope.
vntIndexKey | Required. A Variant value.


Remove method

Removes a member from the collection given an internal ID

Syntax

object.Remove vntIndexKey

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Labels.
vntIndexKey | Required. A Variant value.


Remove method

Removes a member from the collection given an internal ID

Syntax

object.Remove vntIndexKey

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.
vntIndexKey | Required. A Variant value.


Remove method

Removes a member from the collection given an internal ID

Return Type

A Variant value.

Syntax

object.Remove (vntIndexKey)

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangles.
vntIndexKey | Required. A Variant value.


Remove method

Removes a member from the collection given an internal ID

Syntax

object.Remove vntIndexKey

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.
vntIndexKey | Required. A Variant value.


Save method

Save all of the Cell's contents to disk.
The Cell property FilenName must contain a relative path having as a base the project's path.

Syntax

object.Save

The Save method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.


Save method

Syntax

object.Save

The Save method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.


Save method

Saves the project's file ( *.UMLe).

Syntax

object.Save

The Save method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.


Save method

Syntax

object.Save

The Save method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.


SaveAll method

Saves all the project's files ( Including the project File - *.UMLe ).

Syntax

object.SaveAll

The SaveAll method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.


Active property

Returns a boolean value indicating if the rule is to be used by the DRC.

Property type

A Boolean value.

Syntax

object.Active [= value]

The Active property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A Boolean value.


Author property

This property is mantained for backward compatibility.

Property type

A String value.

Syntax

object.Author [= value]

The Author property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


Caption property

The label's caption.

Property type

A String value.

Syntax

object.Caption [= value]

The Caption property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Label.
value | A String value.


CellID property

Returns the internal ID of the pointed Cell.

Property type

A String value.

Syntax

object.CellID [= value]

The CellID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.
value | A String value.


Changed property

Returns a boolean indicating if the Cell's content has been altered since the last time it was saved.

Property type

A Boolean value.

Syntax

object.Changed [= value]

The Changed property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A Boolean value.


Changed property

Returns a boolean indicating if the project's content has been altered since the last time it was saved. This property does not reflect the cells state.

Property type

A Boolean value.

Syntax

object.Changed [= value]

The Changed property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
value | A Boolean value.


Color property

Property type

An OLE_COLOR object.

Syntax

[Set] object.Color [= OLE_COLOR]

The Color property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layer.
OLE_COLOR | An OLE_COLOR object.


Count property

Returns a long containing the number of elements in the collection.

Property type

A Long value.

Syntax

object.Count

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstances.


Count property

Returns a long containing the number of elements in the collection.

Property type

A Long value.

Syntax

object.Count

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cells.


Count property

Returns a long containing the number of elements in the collection.

Property type

A Long value.

Syntax

object.Count

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Envelope.


Count property

Returns a long containing the number of elements in the collection.

Property type

A Long value.

Syntax

object.Count

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Labels.


Count property

Returns a long containing the number of elements in the collection.

Property type

A Long value.

Syntax

object.Count

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.


Count property

Returns a long containing the number of elements in the collection.

Property type

A Long value.

Syntax

object.Count

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.


Description property

Returns/Sets a brief user-entered Cell's description.

Property type

A String value.

Syntax

object.Description [= value]

The Description property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


Distance property

Returns the rule's distance value.

Property type

A Long value.

Syntax

object.Distance [= value]

The Distance property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A Long value.


DistanceType property

Returns the rule's distance type.

Property type

A drcDistanceTypeConstants value.

Syntax

[Set] object.DistanceType [= drcDistanceTypeConstants]

The DistanceType property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
drcDistanceTypeConstants | A drcDistanceTypeConstants value.


FileName property

Returns/sets the filename used to save information to disk. This Filename is relative to the project's path.

Property type

A String value.

Syntax

object.FileName [= value]

The FileName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


FileName property

Property type

A String value.

Syntax

object.FileName [= value]

The FileName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.
value | A String value.


FileName property

The project's file name. This file is defined relative to the project's path.

Property type

A String value.

Syntax

object.FileName [= value]

The FileName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
value | A String value.


FileName property

Property type

A String value.

Syntax

object.FileName [= value]

The FileName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.
value | A String value.


FileVersion property

This property is mantained for backward compatibility.

Property type

A String value.

Syntax

object.FileVersion [= value]

The FileVersion property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


Font property

The font's name.

Property type

A String value.

Syntax

object.Font [= value]

The Font property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Label.
value | A String value.


ID property

Returns/sets the Cell's internal ID. This ID must be unique within the Cells collection.

Property type

A String value.

Syntax

object.ID [= value]

The ID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


ID property

Returns the CellInstance's internal ID.

Property type

A String value.

Syntax

object.ID [= value]

The ID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.
value | A String value.


ID property

The lable's internal ID.

Property type

A Variant value.

Syntax

object.ID [= value]

The ID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Label.
value | A Variant value.


ID property

Property type

A String value.

Syntax

object.ID [= value]

The ID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layer.
value | A String value.


ID property

Rectangle's internal ID.

Property type

A String value.

Syntax

object.ID [= value]

The ID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
value | A String value.


ID property

Rule's internal ID.

Property type

A String value.

Syntax

object.ID [= value]

The ID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A String value.


Ignore45 property

Returns a boolean value indicating if the DRC is to ignore 45 degrees angles.

Property type

A Boolean value.

Syntax

object.Ignore45 [= value]

The Ignore45 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A Boolean value.


IgnoreCoincidences property

Ignores coincidences.

Property type

A Boolean value.

Syntax

object.IgnoreCoincidences [= value]

The IgnoreCoincidences property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A Boolean value.


IgnoreIfL1OutsideL2 property

Ignores if Layer 1 is outside Layer 2.

Property type

A Boolean value.

Syntax

object.IgnoreIfL1OutsideL2 [= value]

The IgnoreIfL1OutsideL2 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A Boolean value.


IgnoreIntersections property

Ignores intersections.

Property type

A Boolean value.

Syntax

object.IgnoreIntersections [= value]

The IgnoreIntersections property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A Boolean value.


IsMaster property

Returns/sets if the cell's is a Master.

Property type

A Boolean value.

Syntax

object.IsMaster [= value]

The IsMaster property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A Boolean value.


IsMaster property

Property type

A Boolean value.

Syntax

object.IsMaster [= value]

The IsMaster property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.
value | A Boolean value.


Item property

Returns the CellInstance element given an internal ID.

Property type

A CellInstance object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstances.
vntIndexKey | Required. A Variant value. Item's internal ID


Item property

Returns the Cell element given an internal ID.

Property type

A Cell object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cells.
vntIndexKey | Required. A Variant value. Item's internal ID


Item property

Returns the point element given an internal index.

Property type

A Point object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Envelope.
vntIndexKey | Required. A Variant value. Item's internal index


Item property

Returns a Label element given an internal ID.

Property type

A Label object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Labels.
vntIndexKey | Required. A Variant value.


Item property

Returns a Layer element given an internal ID.

Property type

A Layer object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.
vntIndexKey | Required. A Variant value.


Item property

Returns a Rectangle element given an internal ID.

Property type

A Rectangle object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangles.
vntIndexKey | Required. A Variant value.


Item property

Returns a Rule element given an internal ID.

Property type

A Rule object.

Syntax

object.Item(vntIndexKey)

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.
vntIndexKey | Required. A Variant value.


Layer property

Rectangle's layer object.

Property type

A Layer object.

Syntax

[Set] object.Layer [= Layer]

The Layer property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
Layer | A Layer object.


Layer1 property

Returns the first Layer object that the rule refers to.

Property type

A Layer object.

Syntax

[Set] object.Layer1 [= Layer]

The Layer1 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
Layer | A Layer object.


Layer2 property

Returns the second Layer object that the rule refers to.

Property type

A Layer object.

Syntax

[Set] object.Layer2 [= Layer]

The Layer2 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
Layer | A Layer object.


Locked property

Returns the locked state of the Cell.
This property is mantained for backward compatibility.
True - the Cell is locked and cannot de edited.
False - the Cell is not locked and can de edited.

Property type

A Boolean value.

Syntax

object.Locked [= value]

The Locked property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A Boolean value.


LogFileName property

The project's log file name. This file is defined in an absolute manner.
This file will only be used if the LogType property is set to logTypeFile

Property type

A String value.

Syntax

object.LogFileName [= value]

The LogFileName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
value | A String value.


LogType property

The project's log type.

Property type

A logTypeConstants value.

Syntax

[Set] object.LogType [= logTypeConstants]

The LogType property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
logTypeConstants | A logTypeConstants value.


LUC property

Returns/sets the Cell's Left Upper Corner (in lambdas).

Property type

A Point object.

Syntax

[Set] object.LUC [= Point]

The LUC property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
Point | A Point object.


Master property

Returns/sets the Cell's master.

Property type

A Cell object.

Syntax

[Set] object.Master [= Cell]

The Master property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
Cell | A Cell object.


Name property

Returns/sets the Cell's user-friendly name.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


Name property

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layer.
value | A String value.


Name property

Rectangle's name.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
value | A String value.


Name property

Returns a User-Friendly name for the Rule.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
value | A String value.


Name property

The name of the rules collection.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.
value | A String value.


NewEnum property

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstances.


NewEnum property

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cells.


NewEnum property

Removes a member from the collection given an internal index.

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Envelope.


NewEnum property

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Labels.


NewEnum property

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layers.


NewEnum property

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangles.


NewEnum property

Property type

An IUnknown object.

Syntax

object.NewEnum

The NewEnum property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.


Organization property

This property is mantained for backward compatibility.

Property type

A String value.

Syntax

object.Organization [= value]

The Organization property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


Path property

Returns the project's absolute path.

Property type

A String value.

Syntax

object.Path [= value]

The Path property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type LayoutProject.
value | A String value.


Pattern property

Property type

A FillStyleConstants object.

Syntax

[Set] object.Pattern [= FillStyleConstants]

The Pattern property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layer.
FillStyleConstants | A FillStyleConstants object.


PlugIn property

Returns the presence state of Plug-In information within the Cell.
This property is mantained for backward compatibility.
True - the Cell has Plug-In information.
False - the Cell hasn't Plug-In information.

Property type

A Boolean value.

Syntax

object.PlugIn [= value]

The PlugIn property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A Boolean value.


PointedCell property

Returns the CellInstance's template Cell.

Property type

A Cell object.

Syntax

[Set] object.PointedCell [= Cell]

The PointedCell property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.
Cell | A Cell object.


Pointer property

This is a free use pointer for placement of aditional information.

Property type

A Variant value.

Syntax

object.Pointer [= value]

The Pointer property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A Variant value.


Position property

The label's position.

Property type

A Point object.

Syntax

[Set] object.Position [= Point]

The Position property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Label.
Point | A Point object.


RLC property

Returns/sets the Cell's Right Lower Corner (in lambdas).

Property type

A Point object.

Syntax

[Set] object.RLC [= Point]

The RLC property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
Point | A Point object.


RulesFile property

This property is mantained for backward compatibility.

Property type

A String value.

Syntax

object.RulesFile [= value]

The RulesFile property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Cell.
value | A String value.


RuleType property

Returns rule's type.

Property type

A drcRuleTypeConstants value.

Syntax

[Set] object.RuleType [= drcRuleTypeConstants]

The RuleType property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rule.
drcRuleTypeConstants | A drcRuleTypeConstants value.


Size property

The font's size.

Property type

A Byte value.

Syntax

object.Size [= value]

The Size property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Label.
value | A Byte value.


Token property

Property type

A String value.

Syntax

object.Token [= value]

The Token property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layer.
value | A String value.


Tolerance property

Returns a Double valu indicating the rules tolerance.

Property type

A Double value.

Syntax

object.Tolerance [= value]

The Tolerance property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rules.
value | A Double value.


X property

Returns the X coordenate for the instance's placement.

Property type

A Long value.

Syntax

object.X [= value]

The X property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.
value | A Long value.


X property

X Coordenate

Property type

A Long value.

Syntax

object.X [= value]

The X property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Point.
value | A Long value.


X1 property

Left Upper Corner X coordenate.

Property type

A Long value.

Syntax

object.X1 [= value]

The X1 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
value | A Long value.


X2 property

Right Lower Corner X coordenate.

Property type

A Long value.

Syntax

object.X2 [= value]

The X2 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
value | A Long value.


Y property

Returns the Y coordenate for the instance's placement.

Property type

A Long value.

Syntax

object.Y [= value]

The Y property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CellInstance.
value | A Long value.


Y property

Y Coordenate

Property type

A Long value.

Syntax

object.Y [= value]

The Y property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Point.
value | A Long value.


Y1 property

Left Upper Corner Y coordenate.

Property type

A Long value.

Syntax

object.Y1 [= value]

The Y1 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
value | A Long value.


Y2 property

Right Lower Corner Y coordenate.

Property type

A Long value.

Syntax

object.Y2 [= value]

The Y2 property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Rectangle.
value | A Long value.


ZOrder property

Property type

A Byte value.

Syntax

object.ZOrder [= value]

The ZOrder property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Layer.
value | A Byte value.


Log event

Syntax

Sub object_Log(LogMessage)

The Log event syntax has these parts:

Part | Description
object | A LayoutProject object.
LogMessage | A String value.


onAddRectangle event

Syntax

Sub object_onAddRectangle(vRectangle)

The onAddRectangle event syntax has these parts:

Part | Description
object | A Rectangles collection.
vRectangle | A Rectangle object.


drcDistanceTypeConstants enumeration

These are the Design Rule Checker constants that define the basic unit of measure.

Members

Constant | Description
drcDistanceTypeAbsoluteValue | Absolute Value based measurements.
drcDistanceTypeLambda | Lambda based measurements.


drcRuleTypeConstants enumeration

These are the Design Rule Checker constants that define the rule type.

Members

Constant | Description
drcRuleTypeMinWidth | Minimum width
drcRuleTypeExactWidth | Exact width
drcRuleTypeNotExist | Not exist
drcRuleTypeOverlap | Overlap
drcRuleTypeSpacing | Spacing
drcRuleTypeSurround | Surround
drcRuleTypeExtension | Extension


logTypeConstants enumeration

These are the Log Type Constants tha define the log's destination.

Members

Constant | Description
logTypenone | No log.
logTypeImmediateWindow | Log to the immediate window.
logTypeFile | Log to file.
logTypeUserDefined | Raise a Log event when a Log is generated inside the Data Structure. The user will respond to this log event acording to his/hers needs.


UMLeEditorTypeConstants enumeration

Members

Constant | Description
UMLeEditorTypeSelection | Selecção de rectângulos
UMLeEditorTypeZoom | Zoom à selecção
UMLeEditorTypeRectangleLayer | Rectangulo de uma dada Layer
UMLeEditorTypeHorizontalLine |
UMLeEditorTypeVerticalLine |